Лаборатория Ubuntu
Опыт установки, настройки и использования
Ubuntu Linux Вопросы и ответы Об Ubuntu Новости Игры Записки для новичка
Поиск:

Полосы при воспроизведении видео | Форум


Вернуться к спискам тем

 Павел Носовский создал тему 21.07.2010 в 14:27
 Новичок  Сообщений: 9
 Репутация: 14

 Сейчас не на форуме
Ubuntu 10.04:При воспроизведении видео в формате avi и DVD - диски, при динамичной сцене (погоня, драка) наблюдаются полосы в изображении.Карточка у меня intel, а именно 00:02.0 VGA compatible controller: Intel Corporation 82Q33 Express Integrated Graphics Controller (rev 02)Драйвера не трогал, какие стояли после установки системы, такие и стоят.Были приняты следующие действия для устранения полос:- Включение VBlanck- Отключение CompizК сожалению оба варианта потерпели неудачу. Плеер: totem-gstreamer, пробовал VLC немного получше, но всеравно полосы присутствуют, просто в чуть меньшем кол-е.Вывод команды glxgears при включенном компизе[spoiler]madest89@hp5800-desktop:~036; glxgears2503 frames in 5.0 seconds1810 frames in 5.0 seconds1794 frames in 5.0 seconds1905 frames in 5.0 seconds1800 frames in 5.0 seconds[/spoiler]При выключенном компизе[spoiler]madest89@hp5800-desktop:~036; glxgears1172 frames in 5.0 seconds1158 frames in 5.0 seconds1123 frames in 5.0 seconds1183 frames in 5.0 seconds1582 frames in 5.0 seconds[/spoiler]Интересно почему без компиза fps меньше чем при включенном?Полосы и прочие бяки отсутствуют на файле в формате mkv.720p (matroska). Видео смотрю через totem-gstreamer, компиз включен, vblanck выключен.http://img710.imageshack.us/f/93223658.png/http://img708.imageshack.us/f/86427044.png/Скрины из видео mkv.1080phttp://img641.imageshack.us/f/85205615.png/http://img38.imageshack.us/f/60199594.png/Что интересно, при снятии скриншотов при проигровании видео, иногда изображения может слегка уползать и появляются полосы (mkv) либо на скрине все очень сильно едет (avidvd). вот пример сериала Lie_to_me в формате avi:http://img203.imageshack.us/f/86920173.png/Ещё хотелось бы отметить, что ролики в mkv явно проигрываются с большим fps, нежели avi, так как последние визуально тормозят и полосят .
Цитировать

 Менеджер по рекламе рекомендует
 Знаток своего дела  Сообщений: 1987
 Репутация: 5055

 Сейчас на форуме

 Константин Кисаринов ответил 21.07.2010 в 14:31
 Юзер  Сообщений: 138
 Репутация: 65

 Сейчас не на форуме
http://habrahabr.ru/blogs/ubuntu/99235/
Цитировать

 Павел Носовский ответил 21.07.2010 в 14:47
 Новичок  Сообщений: 9
 Репутация: 14

 Сейчас не на форуме
Спасибо за ссылку, знаком с данной статьей. Но к сожалению там идет речь о карточках Nvidia и ATi, у меня же intel. Пробовал выполнить пункты по настройки compiz39;а из статьи, они мне не помогли
Цитировать

 Антон Стариков ответил 21.07.2010 в 15:32
 Юзер  Сообщений: 156
 Репутация: 72

 Сейчас не на форуме
ролики в mkv явно проигрываются с большим fps, нежели aviне может быть. это всего-лишь контейнеры и на производительность влиять не могут.
Цитировать

 Павел Носовский ответил 21.07.2010 в 15:57
 Новичок  Сообщений: 9
 Репутация: 14

 Сейчас не на форуме
При просмотре видео в окне GNOME Player (mplayer) выдает стабильно 29.3 кадра в секунду как на видео в HD (в формате mkv), так и на видео в avi. Тормоза становятся заметны (avi) при фулскрине, вот только так как mplayer39;ом снять fps при фулскрине (до этого mplayer39;ом не пользовался, мне totem нравится) .
Цитировать

 Иван Бардов ответил 21.07.2010 в 16:15
 Юзер  Сообщений: 61
 Репутация: 34

 Сейчас не на форуме
мне кажется, что просто видео слабовата для таких задач. как-то и у меня давнееенько в убунте такое было. отключил графические эффекты - пропало.это вина именно убунту с её гномом и компизом. в кубунту такого не было у меня.в арче, генте - и подавно
Цитировать

 Павел Носовский ответил 21.07.2010 в 16:44
 Новичок  Сообщений: 9
 Репутация: 14

 Сейчас не на форуме
Как уже отмечал выше, отключение компиза не помогло. На счет того что видюшка слабовата, почему же тогда HD работает без тормозов?PS: в кубунту теже проблемы.PSS: на семерке с аэро и прочими свистелками работало без полосок :(
Цитировать

 Иван Бардов ответил 21.07.2010 в 17:12
 Юзер  Сообщений: 61
 Репутация: 34

 Сейчас не на форуме
можно поступить таким образом: запустить файлик через mplayer в консольке:mplayer видеофайли смотреть вывод. при обнаружении полосок - закатать весь вывод лога мплеера на какой-нить pastebin и сюда положить ссылку для изучения.если mplayer скажет вдруг среди прочего ***your system is TOO SLOW to play this*** - то всё ясно.---а вообще, теперь (вдруг) кажется мне, что либо ксорг, либо ядро сконфигурены не по-конфигурному. нужно переконфигурировать, перевыконфигурировать
Цитировать

 Ярик Говорун ответил 21.07.2010 в 17:17
 Студент  Сообщений: 292
 Репутация: 127

 Сейчас не на форуме
я бы все таки поставил дрова с оф сайта,мало ли.и еще дикое предположение, мб фреймбуфер? на своей (также интеловской карте) после отключения оного в ядре пропали переодически появляющииеся кратковременно полосы на экране.
Цитировать

 Павел Носовский ответил 21.07.2010 в 18:37
 Новичок  Сообщений: 9
 Репутация: 14

 Сейчас не на форуме
Вот что пишет mplayer:Playing /home/madest89/Видео/Avatar.DVDScr.avi.AVI file format detected.[aviheader] Video stream found, -vid 0[aviheader] Audio stream found, -aid 1VIDEO: [XVID] 592x336 12bpp 23.976 fps 490.4 kbps (59.9 kbyte/s)Clip info: Software: VirtualDubMod 1.5.10.2 (build 2540/release)open: No such file or directory[MGA] Couldn39;t open: /dev/mga_vidopen: No such file or directory[MGA] Couldn39;t open: /dev/mga_vid[VO_TDFXFB] Can39;t open /dev/fb0: Permission denied.[VO_3DFX] Unable to open /dev/3dfx.==========================================================================Opening video decoder: [ffmpeg] FFmpeg39;s libavcodec codec familySelected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)====================================================================================================================================================Opening audio decoder: [mp3lib] MPEG layer-2, layer-3AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000-gt;192000)Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)==========================================================================AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)Starting playback .VDec: vo config request - 592 x 336 (preferred colorspace: Planar YV12)VDec: using Planar YV12 as output csp (no 0)Movie-Aspect is 1.76:1 - prescaling to correct movie aspect.VO: [xv] 592x336 =gt; 592x336 Planar YV12 A: 110.0 V: 110.0 A-V: 0.000 ct: -0.000 2638/2638 1% 0% 0.3% 0 0 Exiting . (Quit)________________________________________________________________А вот для формата mkv:madest89@hp5800-desktop:~036; mplayer /home/madest89/Видео/Face.Off.1997.720p.BluRay.3xRus.Eng.x264-HiDt.mkvMPlayer SVN-r1.0~rc3+svn20090426-4.4.3 (C) 2000-2009 MPlayer Teammplayer: could not connect to socketmplayer: No such file or directoryFailed to open LIRC support. You will not be able to use your remote control.Playing /home/madest89/Видео/Face.Off.1997.720p.BluRay.3xRus.Eng.x264-HiDt.mkv.[mkv] Track ID 1: video (V_MPEG4/ISO/AVC) Face.Off.1997.720p.BluRay.3xRus.Eng.x264-HiDt, -vid 0[mkv] Track ID 2: audio (A_AC3) MVO [AC3 5.1 @ 448 kbps], -aid 0, -alang rus[mkv] Track ID 3: audio (A_AC3) Dubbed [AC3 2.0 @ 192 kbps], -aid 1, -alang rus[mkv] Track ID 4: audio (A_DTS) A. Gavrilov [DTS 5.1 @ ~768 kbps], -aid 2, -alang rus[mkv] Track ID 5: audio (A_DTS) Original [DTS 5.1 @ ~1.5 Mbps], -aid 3, -alang eng[mkv] Track ID 6: subtitles (S_TEXT/UTF8), -sid 0, -slang rus[mkv] Track ID 7: subtitles (S_TEXT/UTF8), -sid 1, -slang eng[mkv] Track ID 8: subtitles (S_TEXT/ASS), -sid 2, -slang eng[mkv] Track ID 9: subtitles (S_TEXT/ASS), -sid 3, -slang ger[mkv] Track ID 10: subtitles (S_TEXT/ASS), -sid 4, -slang fre[mkv] Track ID 11: subtitles (S_TEXT/ASS), -sid 5, -slang spa[mkv] Track ID 12: subtitles (S_TEXT/ASS), -sid 6, -slang por[mkv] Track ID 13: subtitles (S_TEXT/ASS), -sid 7, -slang bul[mkv] Track ID 14: subtitles (S_TEXT/ASS), -sid 8, -slang rum[mkv] Track ID 15: subtitles (S_TEXT/ASS), -sid 9, -slang chi[mkv] Will play video track 1.Matroska file format detected.VIDEO: [avc1] 1280x544 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)open: No such file or directory[MGA] Couldn39;t open: /dev/mga_vidopen: No such file or directory[MGA] Couldn39;t open: /dev/mga_vid[VO_TDFXFB] Can39;t open /dev/fb0: Permission denied.[VO_3DFX] Unable to open /dev/3dfx.==========================================================================Opening video decoder: [ffmpeg] FFmpeg39;s libavcodec codec familySelected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)====================================================================================================================================================Opening
Цитировать


Чтобы ответить, нужно авторизоваться здесь

Страницы: 1 2


Пользователь
Авторизация на сайте:
Email:
Пароль:
Запомнить (Регистрация)

Новости
Ubuntu
Linux
Сайт
Игры
 Игры для Ubuntu
Текущие проблемы:
Странное переключение раскладки
Дата создания: 24.03.2010 0:10
Проблема с асей
Дата создания: 23.03.2010 23:38
ubuntu-10.04-beta1-alternate-i386.iso
Дата создания: 23.03.2010 22:51
Проблемы с FireFox
Дата создания: 23.03.2010 22:34
установка Wine (помощь новичку)
Дата создания: 23.03.2010 20:44
Ищу AVG 7.5
Дата создания: 23.03.2010 20:33

2010-2012 © Лаборатория Ubuntu