Лаборатория Ubuntu
Опыт установки, настройки и использования
Ubuntu Linux Вопросы и ответы Об Ubuntu Новости Игры Записки для новичка
Поиск:

компиляция драйвера Realtek | Форум


Вернуться к спискам тем

 Рамиль Миннигалиев создал тему 29.10.2008 в 21:05
 Новичок  Сообщений: 41
 Репутация: 26

 Сейчас не на форуме
Не завёлся звук на ноуте Asus X58C, в общем стянул драйвер с сайта Realtek, распаковал архив в ~/temp, сделалКод:./configure .sudo makemake не прошёл, получил ошибку:Код: .In file included from /home/thunder/temp/soc/soc-dapm.c:2:/home/thunder/temp/soc/ /alsa-kernel/soc/soc-dapm.c: В функции ‘dapm_pop_time_store’/home/thunder/temp/soc/ /alsa-kernel/soc/soc-dapm.c:834: ошибка: implicit declaration of function ‘strict_strtoul’make[3]: *** [/home/thunder/temp/soc/soc-dapm.o] Ошибка 1make[2]: *** [/home/thunder/temp/soc] Ошибка 2make[1]: *** [_module_/home/thunder/temp] Ошибка 2make[1]: Выход из каталога `/usr/src/linux-headers-2.6.24-21-generic39;make: *** [compile] Ошибка 2Что за байда? Что делать?
Цитировать

 Менеджер по рекламе рекомендует
 Знаток своего дела  Сообщений: 1987
 Репутация: 5055

 Сейчас на форуме

 Иван Соколов ответил 29.10.2008 в 21:34
 Новичок  Сообщений: 12
 Репутация: 15

 Сейчас не на форуме
чонить типа alsa-dev или alsa-lib-dev поставить
Цитировать

 Рамиль Миннигалиев ответил 30.10.2008 в 7:18
 Новичок  Сообщений: 41
 Репутация: 26

 Сейчас не на форуме
alsa-dev и alsa-lib-dev в офф. репозиториях не нашёл, поставил libclalsadrv-dev и libclasladrv1 — не помогло(((
Цитировать

 David Blane ответил 30.10.2008 в 8:30
 Новичок  Сообщений: 7
 Репутация: 13

 Сейчас не на форуме
необходимо установить компиляторский наборsudo apt-get install kernel-package libncurses5-dev fakeroot gcc libc6-devИ еще возможно что-то я упустил, пробей по гуглу
Цитировать

 Рамиль Миннигалиев ответил 30.10.2008 в 14:18
 Новичок  Сообщений: 41
 Репутация: 26

 Сейчас не на форуме
я ставил build-essential, все automake и autoconf. Щас поищу то, что ты предложил
Цитировать

 Рамиль Миннигалиев ответил 30.10.2008 в 19:40
 Новичок  Сообщений: 41
 Репутация: 26

 Сейчас не на форуме
не пошло, та же самая ошибка . фтопку, попробую сначала 8.10, мб там из коробки заведётся . итак времени нет, млин
Цитировать

 Александр Борисов ответил 01.11.2008 в 2:15
 Новичок  Сообщений: 1
 Репутация: 10

 Сейчас не на форуме
Что-то мне помниться,что в том архиве у них есть ещё alsa-lib и alsa-utils. А вообще, ./configure и make там не стоит делать(, там есть свой скрипт ./install который лучше знает как все сделать), если это, конечно, о тех дровах что я думаю .
Цитировать

 Рамиль Миннигалиев ответил 01.11.2008 в 10:53
 Новичок  Сообщений: 41
 Репутация: 26

 Сейчас не на форуме
Александр, в том архиве действительно есть alsa-lib и alsa-utils, но мне нужен только драйвер. В общем, твою подсказку принял, попробую.А 8.10 не понравилась .
Цитировать

 Рамиль Миннигалиев ответил 02.11.2008 в 8:33
 Новичок  Сообщений: 41
 Репутация: 26

 Сейчас не на форуме
Александр, ты прав, запустил скрипт всё вроде как поставилось, установщик нашёл якобы 2 звуковухи, я выбрал, что надо, всё настроилось, сказал типа наслаждайтесь звуком, а его нет(((( В настройках звука везде АЛСА, в микшере всё ползунки на максимум, в переключателях снялк галку с наушников . всё равно звука нет, кто что посоветует?
Цитировать


Чтобы ответить, нужно авторизоваться здесь



Пользователь
Авторизация на сайте:
Email:
Пароль:
Запомнить (Регистрация)

Новости
Ubuntu
Linux
Сайт
Игры
 Игры для Ubuntu
Текущие проблемы:
Skype 2.1 под Ubuntu 9.10 валится
Дата создания: 16.07.2010 22:40
Джойстик как мысь
Дата создания: 16.07.2010 22:37
Ubuntu и 3ds Max
Дата создания: 16.07.2010 21:25
Очень медленно работают Usb девайсы .
Дата создания: 16.07.2010 19:51
Что необходимо доработать?
Дата создания: 16.07.2010 19:18
алгоритм
Дата создания: 16.07.2010 17:26

2010-2012 © Лаборатория Ubuntu